Author - Web Developer - Educator
Found 1 result for tag "420"
RSS Feed

First DoS - and on 4/20!

No, I'm not talking about the Windows DOS, I'm talking about a Denial of Service attack! Yes, between 10am and 1pm today, our company website, shadowdev.com was down. And the worst part is: all of our client sites (and 3rd party websites) that referenced information on our company website took forever to load because they couldn't find the information our site was providing. Here's the Pingdom report from today:

Uptime


Uptime for April 20

Not the best way to spend 4/20, but after finally getting a report from our server hosting company, it turned out that 7 users were accessing the Shell at the same time (with close to 500 requests each), causing the server to allocate all resources to the Shell responses and not allowing the site load properly.

I've never experienced a DoS attack before, but it is not something that I want to deal with again. The oddest thing was: the other sites on the server worked fine (aside from some longer loading times). Out company site was the only one not loading, which is why I thought it was originally a DNS issue. I don't want to say anything about our DNS provider (CloudFlare) since they have been great so far, but based on my experience, that's the only option I was left with in determining the error. The support from CloudFlare was extremely helpful and helped as much as they could, but when our Server folk told us the multiple IP's were the issue, that ruled out any DNS issues.


Tags:#dns #420 #dos #attack #cloudflare #pingdom